RKL eSolutionsBlogs

Sage 500 Supported Versions

What are the Supported Versions of Sage 500 ERP?

In accordance with their software support policy, Sage regularly retires support of older versions of Sage 500 ERP  in order to focus on delivering higher quality support for the latest product releases.

The currently supported versions of Sage 500 ERP include  Version 2013 (7.5),  Version 2014 and Version 2016.  Sage 2013 support will end upon the version 2017 release which is currently targeted for the end of the year 2016.

Refer to the table below for a more detailed list of currently supported versions of Sage 500 ERP along with their planned end-of-support dates.

Sage 500 Supported Versions Sage 500 Supported Versions

SupportedVersionsUpdate_Jan2016

See Also: Version 2016 Updated System Compatibility Requirements

Ready to Upgrade?

Be sure to contact us if you need help with a version that has been retired by Sage or if you’d like help with an upgrade.

Contact RKL eSolutions

Tagged With: Sage 500 ERP

Questions? Need Support?
Get in Touch